<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="user-scalable=yes,width=device-width,minimum-scale=1,initial-scale=1">
<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]-->
<link rel="pingback" href="https://filmschoolrejects.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v15.9.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>‘Girls5eva’ is a Comedic Showstopper from the Producers of ‘30 Rock’</title>
	<meta name="description" content="Girls5eva, a new comedy series hitting Peacock this week, is laugh-out-loud funny and full of catchy original music, says our critic." />
	<link rel="canonical" href="https://filmschoolrejects.com/girls5eva/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="‘Girls5eva’ is a Comedic Showstopper from the Producers of ‘30 Rock’" />
	<meta property="og:description" content="Girls5eva, a new comedy series hitting Peacock this week, is laugh-out-loud funny and full of catchy original music, says our critic." />
	<meta property="og:url" content="https://filmschoolrejects.com/girls5eva/" />
	<meta property="og:site_name" content="Film School Rejects" />
	<meta property="article:publisher" content="https://www.facebook.com/FilmSchoolRejects/" />
	<meta property="article:published_time" content="2021-05-06T00:23:28+00:00" />
	<meta property="article:modified_time" content="2021-05-06T00:01:44+00:00" />
	<meta property="og:image" content="https://filmschoolrejects.com/wp-content/uploads/2021/05/Girls5eva.jpeg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="450" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@aandeandval" />
	<meta name="twitter:site" content="@rejectnation" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Valerie Ettenhofer">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="4 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://filmschoolrejects.com/#organization","name":"Film School Rejects","url":"https://filmschoolrejects.com/","sameAs":["https://www.facebook.com/FilmSchoolRejects/","https://www.instagram.com/thefilmschoolrejects/","https://www.linkedin.com/company-beta/991152/","https://www.youtube.com/user/MoviesWithFSR","https://en.wikipedia.org/wiki/Film_School_Rejects","https://twitter.com/rejectnation"],"logo":{"@type":"ImageObject","@id":"https://filmschoolrejects.com/#logo","inLanguage":"en-US","url":"https://filmschoolrejects.com/wp-content/uploads/2017/03/18199456_1070251983108192_2062824288136651491_n.jpg","width":789,"height":789,"caption":"Film School Rejects"},"image":{"@id":"https://filmschoolrejects.com/#logo"}},{"@type":"WebSite","@id":"https://filmschoolrejects.com/#website","url":"https://filmschoolrejects.com/","name":"Film School Rejects","description":"Movies, TV, and Culture","publisher":{"@id":"https://filmschoolrejects.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://filmschoolrejects.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://filmschoolrejects.com/girls5eva/#primaryimage","inLanguage":"en-US","url":"https://filmschoolrejects.com/wp-content/uploads/2021/05/Girls5eva.jpeg","width":800,"height":450,"caption":"Girls5eva"},{"@type":"WebPage","@id":"https://filmschoolrejects.com/girls5eva/#webpage","url":"https://filmschoolrejects.com/girls5eva/","name":"\u2018Girls5eva\u2019 is a Comedic Showstopper from the Producers of \u201830 Rock\u2019","isPartOf":{"@id":"https://filmschoolrejects.com/#website"},"primaryImageOfPage":{"@id":"https://filmschoolrejects.com/girls5eva/#primaryimage"},"datePublished":"2021-05-06T00:23:28+00:00","dateModified":"2021-05-06T00:01:44+00:00","description":"Girls5eva, a new comedy series hitting Peacock this week, is laugh-out-loud funny and full of catchy original music, says our critic.","breadcrumb":{"@id":"https://filmschoolrejects.com/girls5eva/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://filmschoolrejects.com/girls5eva/"]}]},{"@type":"BreadcrumbList","@id":"https://filmschoolrejects.com/girls5eva/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://filmschoolrejects.com/","url":"https://filmschoolrejects.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://filmschoolrejects.com/girls5eva/","url":"https://filmschoolrejects.com/girls5eva/","name":"\u2018Girls5eva\u2019 is a Comedic Showstopper from the Producers of \u201830 Rock\u2019"}}]},{"@type":["Article","NewsArticle"],"@id":"https://filmschoolrejects.com/girls5eva/#article","isPartOf":{"@id":"https://filmschoolrejects.com/girls5eva/#webpage"},"author":{"@id":"https://filmschoolrejects.com/#/schema/person/764212569acf93d724249ba7cf723f2d"},"headline":"\u2018Girls5eva\u2019 is a Comedic Showstopper from the Producers of \u201830 Rock\u2019","datePublished":"2021-05-06T00:23:28+00:00","dateModified":"2021-05-06T00:01:44+00:00","mainEntityOfPage":{"@id":"https://filmschoolrejects.com/girls5eva/#webpage"},"publisher":{"@id":"https://filmschoolrejects.com/#organization"},"image":{"@id":"https://filmschoolrejects.com/girls5eva/#primaryimage"},"keywords":"Girls5eva,Next Up,Peacock","articleSection":"Columns,Reviews,TV","inLanguage":"en-US","copyrightYear":"2021","copyrightHolder":{"@id":"https://filmschoolrejects.com/#organization"}},{"@type":"Person","@id":"https://filmschoolrejects.com/#/schema/person/764212569acf93d724249ba7cf723f2d","name":"Valerie Ettenhofer","image":{"@type":"ImageObject","@id":"https://filmschoolrejects.com/#personlogo","inLanguage":"en-US","url":"https://filmschoolrejects.com/wp-content/uploads/2019/07/val_2019.jpg","caption":"Valerie Ettenhofer"},"description":"Val is a San Francisco Bay Area freelance writer, TV lover, and cheese plate enthusiast. You can find her @aandeandval wherever social media accounts are sold.","sameAs":["https://twitter.com/aandeandval"]}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel="amphtml" href="https://filmschoolrejects.com/girls5eva/?amp" /><meta name="generator" content="AMP for WP 1.0.76.6"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Film School Rejects &raquo; Feed" href="https://filmschoolrejects.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Film School Rejects &raquo; Comments Feed" href="https://filmschoolrejects.com/comments/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v7.17.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-300648-10"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.17.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-300648-10';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						'dimension1' : 'Valerie Ettenhofer','dimension2' : 'TV','dimension3' : '2021-05-05T19:23:28-05:00','dimension4' : 'good','dimension5' : 'Girls5eva,Next Up,Peacock','dimension6' : 'Girls5eva',                    });
					__gtagTracker( 'config', 'UA-300648-10', {
						allow_anchor:true,forceSSL:true,anonymize_ip:true,link_attribution:true,page_path:location.pathname + location.search + location.hash,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/filmschoolrejects.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://filmschoolrejects.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='mashsb-styles-css'  href='https://filmschoolrejects.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.css?ver=3.7.9' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#cccccc;}@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 177px;}}
</style>
<link rel='stylesheet' id='qc-choice-css'  href='https://filmschoolrejects.com/wp-content/plugins/quantcast-choice/public/css/style.min.css?ver=2.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-fs-publisher-plugin-css'  href='https://filmschoolrejects.com/wp-content/plugins/wp-fs-publisher-plugin-master/public/css/wp-fs-publisher-plugin-public.css?ver=1.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='agg-flex-ads-plugin-css-css'  href='https://filmschoolrejects.com/wp-content/plugins/agg-flex-ads/public/assets/css/agg-flex-ads.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='agg-smart-gif-plugin-css-css'  href='https://filmschoolrejects.com/wp-content/plugins/agg-smart-gif/assets/css/agg-smart-gif.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='mashnet-styles-css'  href='https://filmschoolrejects.com/wp-content/plugins/mashshare-networks/assets/css/mashnet.min.css?ver=2.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://filmschoolrejects.com/wp-content/tablepress-combined.min.css?ver=4' type='text/css' media='all' />
<link rel='stylesheet' id='sanfrancisco-font-css'  href='//fonts.googleapis.com/css?family=Roboto%3A400%2C900%2C700%2C500%2C300%2C400italic%7CMontserrat%3A700&#038;ver=5.7.1#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://filmschoolrejects.com/wp-content/themes/sanfrancisco/library/assets/lib/bootstrap.css?ver=3.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://filmschoolrejects.com/wp-content/themes/sanfrancisco/library/assets/lib/font-awesome-4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='owl-carousel-css'  href='https://filmschoolrejects.com/wp-content/themes/sanfrancisco/library/assets/lib/owl.carousel.2.0.0/assets/owl.carousel.css?ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='sanfrancisco-stylesheet-css'  href='https://filmschoolrejects.com/wp-content/themes/sanfrancisco/style.css?ver=1.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='sanfrancisco-stylesheet-child-css'  href='https://filmschoolrejects.com/wp-content/themes/sanfrancisco-child/style.css?ver=1.3.3' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/filmschoolrejects.com","hash_tracking":"true","ua":"UA-300648-10"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/plugins/google-analytics-premium/assets/js/frontend-gtag.min.js?ver=7.17.0' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='qc-choice-js-extra'>
/* <![CDATA[ */
var choice_cmp_config = {"utid":"77IMnuJabksLA","enabled":"all","ccpa":"","datalayer":""};
/* ]]> */
</script>
<script type='text/javascript' async="async" src='https://filmschoolrejects.com/wp-content/plugins/quantcast-choice/public/js/script.min.js?ver=2.0.4' id='qc-choice-js'></script>
<link rel="https://api.w.org/" href="https://filmschoolrejects.com/wp-json/" /><link rel="alternate" type="application/json" href="https://filmschoolrejects.com/wp-json/wp/v2/posts/365163" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://filmschoolrejects.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://filmschoolrejects.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://filmschoolrejects.com/?p=365163' />
<link rel="alternate" type="application/json+oembed" href="https://filmschoolrejects.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffilmschoolrejects.com%2Fgirls5eva%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://filmschoolrejects.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffilmschoolrejects.com%2Fgirls5eva%2F&#038;format=xml" />

<link rel="icon" href="https://filmschoolrejects.com/wp-content/uploads/2017/03/cropped-ops-new-sq-2.jpg" sizes="32x32" />
<link rel="icon" href="https://filmschoolrejects.com/wp-content/uploads/2017/03/cropped-ops-new-sq-2.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://filmschoolrejects.com/wp-content/uploads/2017/03/cropped-ops-new-sq-2.jpg" />
<meta name="msapplication-TileImage" content="https://filmschoolrejects.com/wp-content/uploads/2017/03/cropped-ops-new-sq-2.jpg" />
<style type="text/css" media="screen">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</style>		<script type="text/javascript">
			window.___gcfg = {lang: 'en'};
			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = '//apis.google.com/js/platform.js';
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();
		</script>
		<script data-cfasync="false" type="text/javascript">
  var freestar = freestar || {};
  freestar.hitTime = Date.now();
  freestar.queue = freestar.queue || [];
  freestar.config = freestar.config || {};
  freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;
  freestar.config.enabled_slots = [];
  !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/filmschoolrejects";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);
  freestar.initCallback = function () { (freestar.config.enabled_slots.length === 0) ? freestar.initCallbackCalled = false : freestar.newAdSlots(freestar.config.enabled_slots) }
</script>

<script data-ad-client="ca-pub-8134601564346940" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>		<style type="text/css" id="wp-custom-css">
			.sf-entry-subtitle {
    font-family: "Roboto",sans-serif;
    font-size: 1.5rem;
}

.sf-entry-subtitle {
    font-family: "Roboto",sans-serif;
    font-size: 1.5rem;
}


.sf-entry-meta {
	font-size:1.2rem;
	
	
}

.sf-entry-meta li.sf-entry-meta-byline img  {
	
	margin-top:7px;
	
}

@media only screen and (min-width: 768px) {
    .sf-entry-singular > .sf-entry-header .breadcrumb {
        float: left;
    }
    
	.sf-entry-singular > .sf-entry-header .sf-entry-meta {
        float: right;
        margin: 0;
    }
    .sf-entry-singular > .sf-entry-header .sf-entry-meta li {
        line-height: 1.6 !important;
    }
    .sf-entry-singular > .sf-entry-header .sf-entry-meta li .sfdate {
        font-size: 16px;
        font-weight: 400;
        color: #a3a3a3;
    }

}

.sf-entry-singular > .sf-entry-header .sf-entry-meta li .sfdate,
.sf-entry-singular > .sf-entry-header .sf-entry-meta li.sf-entry-meta-byline a {
	font-size: 16px;
	color: #a3a3a3;
	font-weight: 400;
}

.sf-entry-singular > .sf-entry-header .sf-entry-meta li.sf-entry-meta-byline a:hover {
	color: inherit;
}

.sf-entry-singular > .sf-entry-header .sf-entry-meta-byline + .sf-entry-meta-date::before {
	content: "|";
	display: inline-block;
	margin-right: .5rem;
	color: #a3a3a3;
	opacity: .5;
}		</style>
		</head>
<body class="post-template-default single single-post postid-365163 single-format-standard">
<nav class="navbar navbar-style-standard navbar-sticky">

	
	<div class="sf-nav-wrapper">

		<div class="container">

			<div class="navbar-header">
				<a href="https://filmschoolrejects.com/" class="navbar-brand"><span class="sf-logo sf-header-logo hidden-xs"><img width="800" height="56" src="https://filmschoolrejects.com/wp-content/uploads/2018/08/rejects-logo-very-wide-800.png" class="attachment-full size-full lazyload agg-fade-in" alt="Rejects Logo Very Wide" data-rjs="https://filmschoolrejects.com/wp-content/uploads/2018/08/rejects-logo-very-wide-1.png" /></span><span class="sf-logo sf-header-logo-mobile visible-xs">Film School Rejects</span></a>				<ul class="navbar-actions">
					<li class="sf-item-search"><a href="https://filmschoolrejects.com/" rel="nofollow" class="sf-btn-search"><span class="fa fa-search"></span></a></li>					<li class="sf-toggle">
						<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false" aria-controls="navbar">
							<span class="sr-only">Toggle navigation</span>
							<span class="fa fa-bars"></span>
						</button>
					</li>
				</ul>
			</div><!-- .navbar-header -->

						<div id="navbar" class="navbar-collapse collapse">

				<ul id="menu-main" class="navbar-nav nav nav-menu"><li id="menu-item-293942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293942"><a href="https://filmschoolrejects.com/section/movies/">Movies</a></li>
<li id="menu-item-293948" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-293948"><a href="https://filmschoolrejects.com/section/tv/">TV</a></li>
<li id="menu-item-354934" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-354934"><a href="https://filmschoolrejects.com/section/lists/">Lists</a></li>
<li id="menu-item-336849" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-336849"><a href="https://filmschoolrejects.com/section/reviews/">Reviews</a></li>
<li id="menu-item-354931" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-354931"><a href="https://filmschoolrejects.com/section/columns/">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-354959" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354959"><a href="https://filmschoolrejects.com/topics/commentary/">Commentary Commentary</a></li>
	<li id="menu-item-354950" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354950"><a href="https://filmschoolrejects.com/topics/ending-explained/">Ending Explained</a></li>
	<li id="menu-item-354941" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354941"><a href="https://filmschoolrejects.com/topics/episodes/">Episodes</a></li>
	<li id="menu-item-354942" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354942"><a href="https://filmschoolrejects.com/topics/filmographies/">Filmographies</a></li>
	<li id="menu-item-354938" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354938"><a href="https://filmschoolrejects.com/topics/horrorscope/">Horrorscope</a></li>
	<li id="menu-item-354943" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354943"><a href="https://filmschoolrejects.com/topics/how/">How&#8217;d They Do That?</a></li>
	<li id="menu-item-354963" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354963"><a href="https://filmschoolrejects.com/topics/movie-dna/">Movie DNA</a></li>
	<li id="menu-item-354944" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354944"><a href="https://filmschoolrejects.com/topics/origin-stories/">Origin Stories</a></li>
	<li id="menu-item-354937" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354937"><a href="https://filmschoolrejects.com/topics/pitch-meeting/">Pitch Meeting</a></li>
	<li id="menu-item-354945" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354945"><a href="https://filmschoolrejects.com/topics/real-stories/">Real Stories</a></li>
	<li id="menu-item-361707" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-361707"><a href="https://filmschoolrejects.com/topics/great-performances/">The Great Performances</a></li>
	<li id="menu-item-354964" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354964"><a href="https://filmschoolrejects.com/topics/the-prime-sublime/">The Prime Sublime</a></li>
	<li id="menu-item-354939" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354939"><a href="https://filmschoolrejects.com/topics/reading-list/">The Reading List</a></li>
	<li id="menu-item-354965" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354965"><a href="https://filmschoolrejects.com/topics/the-queue/">The Queue</a></li>
	<li id="menu-item-357708" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-357708"><a href="https://filmschoolrejects.com/topics/through-a-native-lens/">Through a Native Lens</a></li>
	<li id="menu-item-354957" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354957"><a href="https://filmschoolrejects.com/topics/up-next/">Up Next</a></li>
	<li id="menu-item-354958" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-354958"><a href="https://filmschoolrejects.com/topics/world-builders/">World Builders</a></li>
</ul>
</li>
<li id="menu-item-354936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-354936"><a href="#">Other Features</a>
<ul class="sub-menu">
	<li id="menu-item-293981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293981"><a href="https://filmschoolrejects.com/section/interviews/">Interviews</a></li>
	<li id="menu-item-354932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-354932"><a href="https://filmschoolrejects.com/section/essays/">Essays</a></li>
	<li id="menu-item-354933" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-354933"><a href="https://filmschoolrejects.com/section/streaming/">Streaming Guides</a></li>
	<li id="menu-item-354935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-354935"><a href="https://filmschoolrejects.com/section/projects/">Projects</a></li>
</ul>
</li>
<li id="menu-item-303333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-303333"><a href="#">One Perfect Shot</a>
<ul class="sub-menu">
	<li id="menu-item-303336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-303336"><a href="https://filmschoolrejects.com/topics/one-perfect-shot">Articles Archive</a></li>
	<li id="menu-item-357711" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-357711"><a href="https://twitter.com/OnePerfectShot">Twitter</a></li>
	<li id="menu-item-303335" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-303335"><a href="https://oneperfectshot.substack.com/about">Newsletter</a></li>
</ul>
</li>
<li id="menu-item-328438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-328438"><a href="/about/">About FSR</a></li>
</ul>
			</div><!-- .nav-collapse -->
			
		</div><!-- .container -->

	</div><!-- .sf-nav-wrapper -->

</nav><!-- .navbar -->
<div class="sf-sections-wrapper"><span class="aggads-ad aggads-ad-location-header aggads-ad-type-plain aggads-align-center sf-ad-header-below container aggads-hidden-xs aggads-hidden-sm aggads-hidden-md aggads-visible-lg" data-id="326762"><span class="aggads-inner" style="width:970px;height:250px"><!-- Tag ID: div-gpt-ad-728x90-ATF -->
<div align="center" id="div-gpt-ad-728x90-ATF">
<script data-cfasync="false" type="text/javascript">
    freestar.config.enabled_slots.push({ placementName: "div-gpt-ad-728x90-ATF", slotId: "div-gpt-ad-728x90-ATF" });
</script>
</div></span></span><span class="aggads-ad aggads-ad-location-header aggads-ad-type-plain aggads-align-center sf-ad-header-below container aggads-hidden-xs aggads-hidden-sm aggads-visible-md aggads-hidden-lg" data-id="326762"><span class="aggads-inner" style="width:970px;height:250px"><!-- Tag ID: div-gpt-ad-728x90-ATF -->
<div align="center" id="div-gpt-ad-728x90-ATF">
<script data-cfasync="false" type="text/javascript">
    freestar.config.enabled_slots.push({ placementName: "div-gpt-ad-728x90-ATF", slotId: "div-gpt-ad-728x90-ATF" });
</script>
</div></span></span><span class="aggads-ad aggads-ad-location-header aggads-ad-type-plain aggads-align-center sf-ad-header-below container aggads-hidden-xs aggads-visible-sm aggads-hidden-md aggads-hidden-lg" data-id="326762"><span class="aggads-inner" style="width:970px;height:250px"><!-- Tag ID: div-gpt-ad-728x90-ATF -->
<div align="center" id="div-gpt-ad-728x90-ATF">
<script data-cfasync="false" type="text/javascript">
    freestar.config.enabled_slots.push({ placementName: "div-gpt-ad-728x90-ATF", slotId: "div-gpt-ad-728x90-ATF" });
</script>
</div></span></span><span class="aggads-ad aggads-ad-location-header aggads-ad-type-plain aggads-align-center sf-ad-header-below container aggads-visible-xs aggads-hidden-sm aggads-hidden-md aggads-hidden-lg" data-id="326762"><span class="aggads-inner" style="width:970px;height:250px"><!-- Tag ID: div-gpt-ad-728x90-ATF -->
<div align="center" id="div-gpt-ad-728x90-ATF">
<script data-cfasync="false" type="text/javascript">
    freestar.config.enabled_slots.push({ placementName: "div-gpt-ad-728x90-ATF", slotId: "div-gpt-ad-728x90-ATF" });
</script>
</div></span></span>	<div id="sf-section-post" class="sf-section sf-section-ws sf-section-sidebar-right sf-section-has-sidebar">
		<div class="container">
			<aside class="sf-sidebar"><div class="sf-sidebar-wrapper"><div id="custom_html-6" class="widget_text sidebar-widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Tag ID: div-gpt-ad-300x250-Sidebar -->
<div align="center" id="div-gpt-ad-300x250-Sidebar">
<script data-cfasync="false" type="text/javascript">
    freestar.config.enabled_slots.push({ placementName: "div-gpt-ad-300x250-Sidebar", slotId: "div-gpt-ad-300x250-Sidebar" });
</script>
</div></div></div>
		<div id="recent-posts-2" class="sidebar-widget widget_recent_entries">
		<div class="widget-title"><h2 class="title">Recently Published</h2></div>
		<ul>
											<li>
					<a href="https://filmschoolrejects.com/girls5eva/" aria-current="page">‘Girls5eva’ is a Comedic Showstopper from the Producers of ‘30 Rock’</a>
											<span class="post-date">May 5, 2021</span>
									</li>
											<li>
					<a href="https://filmschoolrejects.com/new-on-hulu-may-2021/">What&#8217;s New to Stream on Hulu for May 2021</a>
											<span class="post-date">May 5, 2021</span>
									</li>
											<li>
					<a href="https://filmschoolrejects.com/steven-yeun/">Steven Yeun&#8217;s Trailblazing Artistry of Feeling</a>
											<span class="post-date">May 5, 2021</span>
									</li>
											<li>
					<a href="https://filmschoolrejects.com/fan-edits/">The Ramifications of Remix Culture: A Brief History of the Fan Edit</a>
											<span class="post-date">May 5, 2021</span>
									</li>
											<li>
					<a href="https://filmschoolrejects.com/star-wars-shots/">The 50 Most Beautiful Shots of The Star Wars Franchise</a>
											<span class="post-date">May 4, 2021</span>
									</li>
											<li>
					<a href="https://filmschoolrejects.com/the-bad-batch-premiere-explained/">Who is Omega? &#8216;Star Wars: The Bad Batch&#8217; Premiere Explained</a>
											<span class="post-date">May 4, 2021</span>
									</li>
											<li>
					<a href="https://filmschoolrejects.com/speed-commentary/">24 Things We Learned from the &#8216;Speed&#8217; Commentary</a>
											<span class="post-date">May 4, 2021</span>
									</li>
											<li>
					<a href="https://filmschoolrejects.com/the-bane-problem-in-the-falcon-and-the-winter-soldier/">Defining &#8220;The Bane Problem&#8221; in &#8216;The Falcon and the Winter Soldier&#8217;</a>
											<span class="post-date">May 3, 2021</span>
									</li>
											<li>
					<a href="https://filmschoolrejects.com/frame-rate-and-animation/">Why a Higher Frame Rate Doesn&#8217;t Automatically Make Animation Better</a>
											<span class="post-date">May 3, 2021</span>
									</li>
											<li>
					<a href="https://filmschoolrejects.com/death-promise-bluray-review-vinegar-syndrome/">Martial Arts and 70s Exploitation Collide in &#8216;Death Promise&#8217;</a>
											<span class="post-date">May 3, 2021</span>
									</li>
					</ul>

		</div></div></aside><div class="sf-main" role="main">		<div id="sf-module-post" class="sf-module sf-module-singular">
			<article class="sf-entry sf-entry-singular post-365163 post type-post status-publish format-standard has-post-thumbnail hentry category-columns category-reviews category-tv tag-girls5eva tag-next-up tag-peacock" itemscope itemtype="https://schema.org/Article"><header class="sf-entry-header"><ol itemscope itemtype="https://schema.org/BreadcrumbList" class="breadcrumb"><li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
					<a itemscope itemtype="https://schema.org/Thing" itemprop="item" href="https://filmschoolrejects.com/">
						<span itemprop="name">Home</span>
					</a>
					<meta itemprop="position" content="1" />
				</li><li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
							<a href="https://filmschoolrejects.com/section/columns/" itemscope itemtype="https://schema.org/Thing" itemprop="item">
								<span itemprop="name">Columns</span>
							</a>
							<meta itemprop="position" content="2" />
						</li><li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
							<a href="https://filmschoolrejects.com/section/reviews/" itemscope itemtype="https://schema.org/Thing" itemprop="item">
								<span itemprop="name">Reviews</span>
							</a>
							<meta itemprop="position" content="3" />
						</li><li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
							<a href="https://filmschoolrejects.com/section/tv/" itemscope itemtype="https://schema.org/Thing" itemprop="item">
								<span itemprop="name">TV</span>
							</a>
							<meta itemprop="position" content="4" />
						</li></ol><ul class="sf-entry-meta clearfix"><li class="sf-entry-meta-byline"><span class="sf-entry-author" itemscope itemtype="https://schema.org/Person">
			<a href="https://filmschoolrejects.com/author/valerie/" rel="author"><span itemprop="author">Valerie Ettenhofer</span>
			</a>
		</span></li><li class="sf-entry-meta-date"><span class="sfdate">May 5, 2021</span></li></ul><h1 class="sf-entry-title" itemprop="headline">‘Girls5eva’ is a Comedic Showstopper from the Producers of ‘30 Rock’</h1><h2 class="sf-entry-subtitle">The latest Peacock series is laugh-out-loud funny and full of catchy original music.</h2></header><figure class="sf-entry-featured-media "><img width="800" height="450" src="https://filmschoolrejects.com/wp-content/uploads/2021/05/Girls5eva.jpeg" class="sf-featured-image attachment-sf-700-525 size-sf-700-525 lazyload agg-fade-in" alt="Girls5eva" data-srcset="https://filmschoolrejects.com/wp-content/uploads/2021/05/Girls5eva.jpeg 800w, https://filmschoolrejects.com/wp-content/uploads/2021/05/Girls5eva-768x432.jpeg 768w" data-sizes="(max-width: 800px) 100vw, 800px" /><div class="sf-entry-flags"></div></figure><div class="sf-entry-content"><aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-buttons"><a class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=%E2%80%98Girls5eva%E2%80%99%20is%20a%20Comedic%20Showstopper%20from%20the%20Producers%20of%20%E2%80%9830%20Rock%E2%80%99&url=https://filmschoolrejects.com/girls5eva/&via=rejectnation" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Tweet</span></a><a class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffilmschoolrejects.com%2Fgirls5eva%2F" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Share</span></a><a class="mashicon-reddit mash-large mash-center mashsb-noshadow" href="http://www.reddit.com/submit?url=https%3A%2F%2Ffilmschoolrejects.com%2Fgirls5eva%2F&amp;title=%E2%80%98Girls5eva%E2%80%99+is+a+Comedic+Showstopper+from+the+Producers+of+%E2%80%9830+Rock%E2%80%99" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Post</span></a><a class="mashicon-flipboard mash-large mash-center mashsb-noshadow" href="https://share.flipboard.com/bookmarklet/popout?v=2&title=%25E2%2580%2598Girls5eva%25E2%2580%2599%2Bis%2Ba%2BComedic%2BShowstopper%2Bfrom%2Bthe%2BProducers%2Bof%2B%25E2%2580%259830%2BRock%25E2%2580%2599&url=https%3A%2F%2Ffilmschoolrejects.com%2Fgirls5eva%2F" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Bookmark</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div>
            </div>
                <div style="clear:both;"></div></aside>
            <!-- Share buttons by mashshare.net - Version: 3.7.9--><p><em>Welcome to <a href="https://filmschoolrejects.com/topics/up-next" target="_blank" rel="noopener noreferrer"><strong>Up Next</strong></a>, a column that gives you the rundown on the latest TV. This week, <a href="https://filmschoolrejects.com/author/valerie/" target="_blank" rel="noopener noreferrer">Valerie Ettenhofer</a> reviews Girls5eva, the new Peacock series from the team behind Unbreakable Kimmy Schmidt.</em></p>
<hr />
<p>The theme song to <strong><em>Girls5eva</em></strong> is both incredibly corny and incredibly catchy. “We’re gonna be famous 5eva, ‘cause 4ever’s 2 short!” a group of women sing while striking poses in bedazzled camo pants and tube tops. The opening credits of the new Peacock series are fitting for a comedy that creatively skewers the absurdity of the music industry, and by the fourth episode of the binge-worthy eight, you’ll most likely find yourself singing along. <em>Girls5eva</em> is impossible to resist, the rare recent sitcom whose debut season is laugh-out-loud funny from beginning to end.</p>
<p>The series follows a former ‘90s girl group that tries to make a comeback when an up-and-coming rapper samples their lone chart-topping song. For a brief period, this group was on the edge of superstardom, but they’ve long since been out of the biz. As one character says, “It’s been an entire Zendaya since you last recorded.” Anxiety-prone New York mom Dawn (<strong>Sara Bareilles</strong>), broke diva Wickie (<strong>Renée Elise Goldsberry</strong>), lesbian dentist Gloria (<strong>Paula Pell</strong>), and would-be Real Housewife Summer (<strong>Busy Philipps</strong>) reunite in an effort to jumpstart their lives, and the resulting chaos is incredibly entertaining.</p>
<p><em>Girls5eva</em> is created by <em>The Colbert Report</em> and <em>Unbreakable Kimmy Schmidt</em> writer <strong>Meredith Scardino</strong> and counts several of the key players behind <a href="https://filmschoolrejects.com/every-episode-of-30-rock-ranked/" target="_blank" rel="noopener"><em>30 Rock</em></a>, including <strong>Tina Fey</strong>, <strong>Jeff Richmond</strong>, and <strong>Robert Carlock</strong>, among its producers. It&#8217;s the type of comedy that flings out jokes a minute, successfully landing surprising and bizarre punchlines about everything from water bras to hermit crab shells. One of the regular targets is the kitschy time capsule of the late ‘90s, captured in uproariously accurate faux-archival footage from MTV shows like <em>TRL</em> and <em>Cribs</em>, and in the group&#8217;s songs, which are hilariously moment-specific.</p>
<p>The series trades in rapid-speed pop culture references that will especially tickle music fans, but like<em> 30 Rock</em>, it has a wide comedic range that’s much broader &#8212; and stranger &#8212; than any one topic. At one point, Dawn worries that her precocious only child is becoming a “New York Lonely Boy,” a term that comes with its own theme song and a surprise celebrity cameo. A side plot centered on Summer’s ultra-distant marriage to clearly gay boy-band alum Kev (<strong>Andrew Rannells</strong>) is side-splittingly silly. <em>Girls5eva</em> gambles big with its casting choices, specifically the inclusion of musician Bareilles and Broadway star Goldsberry. Fortunately, both not only hold their own among a cast of clowns but often deliver the funniest punchlines.</p>
<p>In an era of television genre-blending, it’s refreshing to find a comedy series that’s guaranteed to make you laugh out loud. <em>Girls5eva</em> is especially welcome because, unlike other shows from Fey and co., including <em>Unbreakable Kimmy Schmidt</em> and <em>30 Rock</em>, there’s no icky, off-color undercurrent. In a world that’s become keenly aware of sitcoms’ long history of racial stereotyping, the phrase “produced <a href="https://www.newsweek.com/tina-fey-30-rock-asians-1512806" target="_blank" rel="noopener">by Tina Fey</a>” doesn’t instill as much confidence as it once did. Thankfully, this series manages to be sharp and surprising without punching down. It is written as, among other things, a wry critique of the entertainment industry’s long history of blatant exploitation, faux-feminism, and generally soul-crushing tactics.</p>
<p>The musical TV series, once a maligned genre, has been reinvigorated in recent years by shows like <strong><em>Zoey’s Extraordinary Playlist</em> </strong>and <em><strong><a href="https://filmschoolrejects.com/crazy-ex-girlfriend/" target="_blank" rel="noopener">Crazy Ex-Girlfriend</a></strong></em>.<em> Girls5eva</em> is a deserving addition to the list, with songs that beg to be replayed. The group’s older stuff cleverly satirizes an era of problematic pop with shallow, girl-power lyrics, while their comeback music is equally catchy but slightly deeper. Songs are often played in passing in an episode, only for a fuller, studio version to appear over the end credits. The latter quickly becomes a special treat to look forward to, like a Marvel post-credits scene for a version of The Avengers made up of talented women in their forties. “Space Boys,” a high-concept jam about searching the galaxy for kissable males, is genuinely catchy, while the savagely funny “Dream Girlfriends” rattles off a list of supposedly attractive qualities, like a willingness to let one’s boyfriend talk about Quentin Tarantino.</p>
<p>To date, Peacock’s original series offerings have been hit or miss, but <em>Girls5eva</em> feels like a breakthrough for the streamer. The riotous, whip-smart series is a return to form for a network &#8212; NBC &#8212; that was once home to many of the best and boldest sitcoms on network TV. With comedy performed at breakneck speeds, a cast that’s totally game, and a seemingly endless supply of earworms on hand, <em>Girls5eva</em> is sure to be more than a one-hit-wonder.</p>
</div><div class="sf-entry-tags-box"><p class="sf-entry-tags sf-eb-item"><span class="sf-label">Tags:</span><span class="sf-tag"><a href="https://filmschoolrejects.com/topics/girls5eva/">Girls5eva</a></span><span class="sf-tag"><a href="https://filmschoolrejects.com/topics/next-up/">Next Up</a></span><span class="sf-tag"><a href="https://filmschoolrejects.com/topics/peacock/">Peacock</a></span></p></div><div class="sf-author-box" itemscope itemtype="https://schema.org/Person">
	<header class="sf-author-title">
		<h2 class="title">
			<a href="https://filmschoolrejects.com/author/valerie/" rel="author">Valerie Ettenhofer</a>		</h2>
	</header>
	<figure class="sf-author-avatar">
		<a href="https://filmschoolrejects.com/author/valerie/" rel="author"><img src="https://filmschoolrejects.com/wp-content/uploads/2019/07/val_2019.jpg" width="120" height="120" alt="Valerie Ettenhofer" class="avatar avatar-120 wp-user-avatar wp-user-avatar-120 alignnone photo" /></a>	</figure>
	<div class="sf-author-bio" itemprop="description">
		<p>Val is a San Francisco Bay Area freelance writer, TV lover, and cheese plate enthusiast. You can find her @aandeandval wherever social media accounts are sold.</p>
	</div>
	<div class="sf-author-social">
		<ul>
						<li><a href="https://twitter.com/aandeandval" target="_blank"><span class="fa fa-twitter" rel="nofollow"></span></a></li>
						<li><a href="/cdn-cgi/l/email-protection#e99f8885a98f8085849a8a818686859b8c838c8a9d9ac78a8684" target="_blank"><span class="fa fa-envelope" rel="nofollow"></span></a></li>
					</ul>
	</div>
</div></article>		</div>
		</div>		</div>
	</div>
	<span class="sf-bg-fixed"></span></div><!-- .sections-wrapper --><footer class="sf-footer">
	<div class="container">

		
				<div class="sf-footer-bottom row">

			<hr />

			<div class="col-md-6">
				<p class="sf-footer-copyright-text">
									</p>
			</div>

						<div class="col-md-6">
				<ul id="menu-footer" class="sf-footer-nav"><li id="menu-item-15" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15"><a href="/about">About</a></li>
<li id="menu-item-98457" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98457"><a href="https://filmschoolrejects.com/advertise/">Advertise</a></li>
<li id="menu-item-98459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98459"><a href="https://filmschoolrejects.com/copyright/">© Reject Media 2018</a></li>
</ul>			</div>
			
		</div><!-- .sf-footer-bottom -->
		
	</div><!-- .container -->
</footer><!-- .sf-footer -->

<div id="freestar">
	 <img src="data:image/svg+xml;base64,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" alt="Freestar" width="17" height="18" /> <a href="https://freestar.io/" target="_blank">Publisher Operations by Freestar</a>.  <a href="https://filmschoolrejects.com/bad-ads" target="_blank" class="underline">Report an ad</a>
</div><!-- Freestar -->
<div class="sf-search-form-fs"><form class="search-form" method="get" action="https://filmschoolrejects.com/">
					 <span class="sf-close"><span class="fa fa-times"></span></span>
				    <div class="input-group">
				        <span class="input-group-addon" id="searchAddon1"><span class="fa fa-search"></span></span>
		                <input type="text" name="s" class="form-control" autocomplete="off" placeholder="Search..." title="Search for:" value="" aria-describedby="searchAddon1" />
	                </div>
	            </form></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">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</script><script type='text/javascript' id='mashsb-js-extra'>
/* <![CDATA[ */
var mashsb = {"shares":"0","round_shares":"","animate_shares":"0","dynamic_buttons":"0","share_url":"https:\/\/filmschoolrejects.com\/girls5eva\/","title":"%E2%80%98Girls5eva%E2%80%99+is+a+Comedic+Showstopper+from+the+Producers+of+%E2%80%9830+Rock%E2%80%99","image":"https:\/\/filmschoolrejects.com\/wp-content\/uploads\/2021\/05\/Girls5eva.jpeg","desc":"The latest Peacock series is laugh-out-loud funny and full of catchy original music.","hashtag":"rejectnation","subscribe":"link","subscribe_url":"http:\/\/eepurl.com\/bWTfMf","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"0","nonce":"3a5bf1e97e","postid":"365163","servertime":"1620271731","ajaxurl":"https:\/\/filmschoolrejects.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.js?ver=3.7.9' id='mashsb-js'></script>
<script type='text/javascript' id='wp-fs-publisher-plugin-js-extra'>
/* <![CDATA[ */
var wp_template = {"template_name":"single.php","template_dir":"sanfrancisco","all_files":"[\"themes-controller.php\",\"themes.php\",\"themes\\\/sanfrancisco-child\\\/functions.php\",\"themes\\\/sanfrancisco\\\/functions.php\",\"themes\\\/sanfrancisco\\\/library\\\/core\\\/helpers.php\",\"themes\\\/sanfrancisco\\\/library\\\/core\\\/theme-support.php\",\"themes\\\/sanfrancisco\\\/library\\\/core\\\/template-tags.php\",\"themes\\\/sanfrancisco\\\/library\\\/core\\\/scripts.php\",\"themes\\\/sanfrancisco\\\/library\\\/core\\\/widgets.php\",\"themes\\\/sanfrancisco\\\/library\\\/core\\\/filters.php\",\"themes\\\/sanfrancisco\\\/library\\\/mco-theme-options\\\/mco-theme-options.php\",\"themes\\\/sanfrancisco\\\/library\\\/admin\\\/admin.php\",\"themes\\\/sanfrancisco\\\/library\\\/admin\\\/tgm.php\",\"themes\\\/sanfrancisco\\\/library\\\/admin\\\/includes\\\/TGM-Plugin-Activation\\\/class-tgm-plugin-activation.php\",\"themes\\\/sanfrancisco\\\/library\\\/widgets\\\/fancy-posts.php\",\"themes\\\/sanfrancisco\\\/library\\\/widgets\\\/facebook-box.php\",\"themes\\\/sanfrancisco\\\/library\\\/widgets\\\/google-plus-box.php\",\"themes\\\/sanfrancisco\\\/library\\\/widgets\\\/instagram-feed.php\",\"themes\\\/sanfrancisco\\\/library\\\/widgets\\\/social-media-icons.php\",\"themes\\\/sanfrancisco\\\/library\\\/widgets\\\/about-me.php\",\"themes\\\/sanfrancisco\\\/library\\\/assets\\\/lib\\\/class-hybrid-media-grabber.php\",\"themes\\\/sanfrancisco\\\/library\\\/assets\\\/lib\\\/class-agg-option-styles.php\",\"themes\\\/sanfrancisco\\\/single.php\",\"themes\\\/sanfrancisco\\\/header.php\",\"themes\\\/sanfrancisco\\\/library\\\/templates\\\/loop-section.php\",\"themes\\\/sanfrancisco\\\/library\\\/templates\\\/loop-module.php\",\"themes\\\/sanfrancisco\\\/library\\\/templates\\\/tpl-singular.php\",\"themes\\\/sanfrancisco\\\/library\\\/templates\\\/tpl-author_box.php\",\"themes\\\/sanfrancisco\\\/footer.php\"]"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/plugins/wp-fs-publisher-plugin-master/public/js/wp-fs-publisher-plugin-public.js?ver=1.1.4' id='wp-fs-publisher-plugin-js'></script>
<script type='text/javascript' id='agg-flex-ads-plugin-js-js-extra'>
/* <![CDATA[ */
var aggads_l10n = {"ajaxurl":"https:\/\/filmschoolrejects.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/plugins/agg-flex-ads/public/assets/js/agg-flex-ads.js?ver=1.0.0' id='agg-flex-ads-plugin-js-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/plugins/agg-smart-gif/assets/js/agg-smart-gif.js?ver=1.0.0' id='agg-smart-gif-plugin-js-js'></script>
<script type='text/javascript' id='mashnet-js-extra'>
/* <![CDATA[ */
var mashnet = {"body":"","subject":"","pinterest_select":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/plugins/mashshare-networks/assets/js/mashnet.min.js?ver=2.4.6' id='mashnet-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/themes/sanfrancisco/library/assets/lib/bootstrap-3.3.6/js/bootstrap.min.js?ver=3.3.6' id='bootstrap-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/themes/sanfrancisco/library/assets/lib/owl.carousel.2.0.0/owl.carousel.min.js?ver=2.0.0' id='owl-carousel-js'></script>
<script type='text/javascript' id='sanfrancisco-main-js-extra'>
/* <![CDATA[ */
var sf_l10n = {"ajaxurl":"https:\/\/filmschoolrejects.com\/wp-admin\/admin-ajax.php","post_id":"365163"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/themes/sanfrancisco/library/assets/js/sf-main.js?ver=1.3.3' id='sanfrancisco-main-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
<!-- Tag ID: connatix-video-mobile -->
<div id="connatix-video-mobile">
</div>

<!-- Tag ID: Connatix-video -->
<div id="Connatix-video">
</div>

<!-- Tag ID: FilmSchoolRejects_1x1 -->
<div align="center" id="FilmSchoolRejects_1x1">
<script data-cfasync="false" type="text/javascript">
    freestar.config.enabled_slots.push({ placementName: "FilmSchoolRejects_1x1", slotId: "FilmSchoolRejects_1x1" });
</script>
</div></body>
</html>