<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset="UTF-8" />
    
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://filmschoolrejects.com/xmlrpc.php" />
    <!-- FAVICON: Upload an ICO image to the Images folder labeled favicon.ico -->
    <link rel="shortcut icon" href="https://rejectswp.staging.wpengine.com/wp-content/uploads/logos/favicon.ico" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v17.0 (Yoast SEO v17.0) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>The Eyes of Tammy Faye is Appropriately Campy and Flawed</title>
	<meta name="description" content="We review The Eyes of Tammy Faye, a thoroughly enjoyable if surface-deep biopic grounded by a captivating performance from Jessica Chastain." />
	<link rel="canonical" href="https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="TIFF 2021: &#039;The Eyes of Tammy Faye&#039; is Appropriately Campy and Flawed" />
	<meta property="og:description" content="We review The Eyes of Tammy Faye, a thoroughly enjoyable if surface-deep biopic grounded by a captivating performance from Jessica Chastain." />
	<meta property="og:url" content="https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/" />
	<meta property="og:site_name" content="Film School Rejects" />
	<meta property="article:publisher" content="https://www.facebook.com/FilmSchoolRejects/" />
	<meta property="article:published_time" content="2021-09-16T01:16:55+00:00" />
	<meta property="article:modified_time" content="2021-09-16T01:52:47+00:00" />
	<meta property="og:image" content="https://filmschoolrejects.com/wp-content/uploads/2021/08/the-eyes-of-tammy-faye-jessica-chastain.jpg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="562" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@TheWorstNun" />
	<meta name="twitter:site" content="@rejectnation" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Meg Shields" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://filmschoolrejects.com/#organization","name":"Film School Rejects","url":"https://filmschoolrejects.com/","sameAs":["https://www.facebook.com/FilmSchoolRejects/","https://www.instagram.com/thefilmschoolrejects/","https://www.linkedin.com/company-beta/991152/","https://www.youtube.com/user/MoviesWithFSR","https://en.wikipedia.org/wiki/Film_School_Rejects","https://twitter.com/rejectnation"],"logo":{"@type":"ImageObject","@id":"https://filmschoolrejects.com/#logo","inLanguage":"en-US","url":"https://filmschoolrejects.com/wp-content/uploads/2021/07/fsr-site-icon.png","contentUrl":"https://filmschoolrejects.com/wp-content/uploads/2021/07/fsr-site-icon.png","width":512,"height":512,"caption":"Film School Rejects"},"image":{"@id":"https://filmschoolrejects.com/#logo"}},{"@type":"WebSite","@id":"https://filmschoolrejects.com/#website","url":"https://filmschoolrejects.com/","name":"Film School Rejects","description":"Movies, TV, and Culture","publisher":{"@id":"https://filmschoolrejects.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://filmschoolrejects.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/#primaryimage","inLanguage":"en-US","url":"https://filmschoolrejects.com/wp-content/uploads/2021/08/the-eyes-of-tammy-faye-jessica-chastain.jpg","contentUrl":"https://filmschoolrejects.com/wp-content/uploads/2021/08/the-eyes-of-tammy-faye-jessica-chastain.jpg","width":800,"height":562,"caption":"The Eyes Of Tammy Faye Jessica Chastain"},{"@type":"WebPage","@id":"https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/#webpage","url":"https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/","name":"The Eyes of Tammy Faye is Appropriately Campy and Flawed","isPartOf":{"@id":"https://filmschoolrejects.com/#website"},"primaryImageOfPage":{"@id":"https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/#primaryimage"},"datePublished":"2021-09-16T01:16:55+00:00","dateModified":"2021-09-16T01:52:47+00:00","description":"We review The Eyes of Tammy Faye, a thoroughly enjoyable if surface-deep biopic grounded by a captivating performance from Jessica Chastain.","breadcrumb":{"@id":"https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/"]}]},{"@type":"BreadcrumbList","@id":"https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://filmschoolrejects.com/"},{"@type":"ListItem","position":2,"name":"TIFF 2021: &#8216;The Eyes of Tammy Faye&#8217; is Appropriately Campy and Flawed"}]},{"@type":["Article","NewsArticle"],"@id":"https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/#article","isPartOf":{"@id":"https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/#webpage"},"author":{"@id":"https://filmschoolrejects.com/#/schema/person/3e0a3a1e20c1ea0900e80fa9244cface"},"headline":"TIFF 2021: &#8216;The Eyes of Tammy Faye&#8217; is Appropriately Campy and Flawed","datePublished":"2021-09-16T01:16:55+00:00","dateModified":"2021-09-16T01:52:47+00:00","mainEntityOfPage":{"@id":"https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/#webpage"},"wordCount":1037,"publisher":{"@id":"https://filmschoolrejects.com/#organization"},"image":{"@id":"https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/#primaryimage"},"thumbnailUrl":"https://filmschoolrejects.com/wp-content/uploads/2021/08/the-eyes-of-tammy-faye-jessica-chastain.jpg","keywords":["Toronto International Film Festival (TIFF)"],"articleSection":["Movies","Reviews"],"inLanguage":"en-US","copyrightYear":"2021","copyrightHolder":{"@id":"https://filmschoolrejects.com/#organization"}},{"@type":"Person","@id":"https://filmschoolrejects.com/#/schema/person/3e0a3a1e20c1ea0900e80fa9244cface","name":"Meg Shields","image":{"@type":"ImageObject","@id":"https://filmschoolrejects.com/#personlogo","inLanguage":"en-US","url":"https://filmschoolrejects.com/wp-content/uploads/2019/07/meg.jpg","contentUrl":"https://filmschoolrejects.com/wp-content/uploads/2019/07/meg.jpg","caption":"Meg Shields"},"description":"Meg Shields is the humble farm boy of your dreams and a senior contributor at Film School Rejects. She currently runs three columns at FSR: The Queue, How'd They Do That?, and Horrorscope. She is also a curator for One Perfect Shot and a freelance writer for hire. Meg can be found screaming about John Boorman's 'Excalibur' on Twitter here: @TheWorstNun. (She/Her).","sameAs":["http://filmschoolrejects.com","https://twitter.com/TheWorstNun"],"url":"https://filmschoolrejects.com/author/meg/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel="amphtml" href="https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/?amp" /><meta name="generator" content="AMP for WP 1.0.77.20"/><link rel='dns-prefetch' href='//s.w.org' />
<style>.monsterinsights-async-hide { opacity: 0 !important} </style>
<script data-cfasync="false">(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;
h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};
(a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;
})(window,document.documentElement,'monsterinsights-async-hide','dataLayer',4000,
{'GTM-T3DHMDM':true});</script>
    <script src="https://www.googleoptimize.com/optimize.js?id=GTM-T3DHMDM" onerror="dataLayer.hide.end && dataLayer.hide.end()"></script>
    		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.0.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-300648-10"  type="text/javascript" data-cfasync="false" async></script>
			<script type="text/javascript" data-cfasync="false">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</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/filmschoolrejects.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://filmschoolrejects.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='qc-choice-css'  href='https://filmschoolrejects.com/wp-content/plugins/quantcast-choice/public/css/style.min.css?ver=2.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-frontend-css'  href='https://filmschoolrejects.com/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=3.1.17' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-flatpickr-css'  href='https://filmschoolrejects.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.1.17' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-select2-css'  href='https://filmschoolrejects.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='agg-smart-gif-plugin-css-css'  href='https://filmschoolrejects.com/wp-content/plugins/agg-smart-gif/assets/css/agg-smart-gif.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap_grid_css-css'  href='https://filmschoolrejects.com/wp-content/themes/furiosa/css/bootstrap-grid.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='main_css-css'  href='https://filmschoolrejects.com/wp-content/themes/furiosa/style.css?ver=1628022751' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://filmschoolrejects.com/wp-content/tablepress-combined.min.css?ver=10' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/filmschoolrejects.com","hash_tracking":"true","ua":"UA-300648-10","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/plugins/google-analytics-premium/assets/js/frontend-gtag.min.js?ver=8.0.0' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' id='qc-choice-js-extra'>
/* <![CDATA[ */
var choice_cmp_config = {"utid":"77IMnuJabksLA","enabled":"all","ccpa":"","datalayer":""};
/* ]]> */
</script>
<script type='text/javascript' async="async" src='https://filmschoolrejects.com/wp-content/plugins/quantcast-choice/public/js/script.min.js?ver=2.0.4' id='qc-choice-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=5.8' id='ppress-flatpickr-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=5.8' id='ppress-select2-js'></script>
<link rel="https://api.w.org/" href="https://filmschoolrejects.com/wp-json/" /><link rel="alternate" type="application/json" href="https://filmschoolrejects.com/wp-json/wp/v2/posts/367718" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://filmschoolrejects.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://filmschoolrejects.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://filmschoolrejects.com/?p=367718' />
<link rel="alternate" type="application/json+oembed" href="https://filmschoolrejects.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffilmschoolrejects.com%2Fthe-eyes-of-tammy-faye-review%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://filmschoolrejects.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffilmschoolrejects.com%2Fthe-eyes-of-tammy-faye-review%2F&#038;format=xml" />
    <script>
		if(screen.width<769){
        	window.location = "https://filmschoolrejects.com/the-eyes-of-tammy-faye-review/?amp";
        }
    	</script>
<link rel="icon" href="https://filmschoolrejects.com/wp-content/uploads/2021/07/cropped-fsr-site-icon.png" sizes="32x32" />
<link rel="icon" href="https://filmschoolrejects.com/wp-content/uploads/2021/07/cropped-fsr-site-icon.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://filmschoolrejects.com/wp-content/uploads/2021/07/cropped-fsr-site-icon.png" />
<meta name="msapplication-TileImage" content="https://filmschoolrejects.com/wp-content/uploads/2021/07/cropped-fsr-site-icon.png" />
    <!-- READ THIS: You can add additional code after this line. -->
	<link rel="stylesheet" href="https://a.pub.network/core/pubfig/cls.css">
<script data-cfasync="false" type="text/javascript">
  var freestar = freestar || {};
  freestar.queue = freestar.queue || [];
  freestar.config = freestar.config || {};
  freestar.config.enabled_slots = [];
  freestar.initCallback = function () { (freestar.config.enabled_slots.length === 0) ? freestar.initCallbackCalled = false : freestar.newAdSlots(freestar.config.enabled_slots) }
</script>
<script src="https://a.pub.network/filmschoolrejects/pubfig.min.js" async></script>
</head>

<body class="post-template-default single single-post postid-367718 single-format-standard">

<!-- START HEADER -->
<header class="header blue-bg no-underline py-3">
    <div class="container">
        <div class="row justify-content-center align-items-center text-center">
          
        <!-- START LOGO: Upload an SVG image to the Images folder labeled logo.svg -->
        <div title="Logo" class="col-md order-md-3">
            <a href="/" class="no-hover">
                <img src="/wp-content/uploads/logos/logo.png" alt="Film School Rejects Logo" class="img-fluid logo" width="300" height="57">
            </a>
        </div>
        <!-- END LOGO -->
        
        <!-- START NAVIGATION MENU -->
        <div class="col order-1"><a href="/" class="white">Home</a></div>
        <div class="col order-2"><a href="/about/" class="white">About</a></div>
        <div class="col order-4"><a href="/section/columns/" class="white">Features</a></div>
        <div class="col order-5"><a href="/search/" class="white">Search</a></div>
        <!-- END NAVIGATION MENU -->
        
        </div>
    </div>
</header>
<!-- END HEADER -->

<!-- START ARTICLE -->
<div class="container py-5">
	 <div class="row align-items-center justify-content-center my-2 text-center medium black">
		 <span class="mx-1">
			 <a href="https://filmschoolrejects.com/section/movies/" alt="View all posts in Movies">Movies</a> &#183; <a href="https://filmschoolrejects.com/section/reviews/" alt="View all posts in Reviews">Reviews</a></span>
	</div>
    <h1 class="black text-center">TIFF 2021: &#8216;The Eyes of Tammy Faye&#8217; is Appropriately Campy and Flawed</h1>
    <div class="row align-items-center justify-content-center my-3 text-center medium dark-gray">
		 <span class="mx-1">Extravagant and charming, but with some bumps along the way, this is a biopic befitting its larger-than-life subject.</span>
	</div>
    <article class="article">

        
		
                    <figure class="sf-entry-featured-media ">
                <img width="800" height="562" src="https://filmschoolrejects.com/wp-content/uploads/2021/08/the-eyes-of-tammy-faye-jessica-chastain.jpg" class="articlethumb wp-post-image" alt="The Eyes Of Tammy Faye Jessica Chastain" loading="lazy" srcset="https://filmschoolrejects.com/wp-content/uploads/2021/08/the-eyes-of-tammy-faye-jessica-chastain.jpg 800w, https://filmschoolrejects.com/wp-content/uploads/2021/08/the-eyes-of-tammy-faye-jessica-chastain-768x540.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" />                                    <div class="sf-entry-flags">
                        <span class="sf-entry-flag sf-entry-flag-creditline">Fox Searchlight</span>
                    </div>
                            </figure>
		        
        <!-- START BYLINE -->
        <div class="row align-items-center justify-content-center my-4 text-center medium dark-gray">
            By&nbsp;<a href="https://filmschoolrejects.com/author/meg/" title="Posts by Meg Shields" class="author url fn" rel="author">Meg Shields</a>&nbsp;and&nbsp;<a href="https://filmschoolrejects.com/author/swanson/" title="Posts by Anna Swanson" class="author url fn" rel="author">Anna Swanson</a>&nbsp;&#183; Published on September 15th, 2021 
            </div>
        <!-- END BYLINE -->
		      
        <p><em>This review of The Eyes of Tammy Faye is part of our <a href="https://filmschoolrejects.com/topics/tiff/" target="_blank" rel="noopener">ongoing press coverage of the Toronto International Film Festival</a>. From reviews to interviews to recap lists, follow along for all things TIFF 2021.</em></p>
<hr />
<p><span style="font-weight: 400;">We hope none of you reading this keeps kosher because this movie is full of ham. </span><strong><i>The Eyes of Tammy Faye </i></strong><span style="font-weight: 400;">is as flamboyant, charming, and flawed as its subject. Anchored by an exceptional leading performance by <a href="https://filmschoolrejects.com/topics/jessica-chastain/" target="_blank" rel="noopener"><strong>Jessica Chastain</strong></a>, the biopic is also thoroughly enjoyable despite its adherence to expected and boilerplate genre conventions.</span></p>
<p>Chastain portrays <a href="https://en.wikipedia.org/wiki/Tammy_Faye_Messner" target="_blank" rel="noopener">Tammy Faye Baker</a>, the eccentric televangelist, from aspiring preacher to tabloid cover girl. As a young woman,<span style="font-weight: 400;"> her unwavering faith leads her to North Central Bible College, where she falls head over heels for Jim Bakker (<a href="https://filmschoolrejects.com/topics/andrew-garfield/" target="_blank" rel="noopener"><strong>Andrew Garfield</strong></a>), a soft-spoken charmer who believes that God wants people to have fun and be rich. </span><span style="font-weight: 400;">The couple shares an unbridled ambition to earnestly merge faith and entertainment, which takes the shape of wildly popular television programming that brings the vibrancy of the Church into people’s living rooms. But eventually, personal and financial scandals lead to trouble in paradise.</span></p>
<p><span style="font-weight: 400;">The sensational story of the Bakkers’ fall from literal grace is sure to captivate those familiar with and/or fascinated by American religious fundamentalism. In 1989, Jim Bakker was indicted, convicted, and imprisoned on a long list of fraud and conspiracy charges, leading to the dissolution of their multimillion-dollar ministry empire. <i>The Eyes of Tammy Faye </i>depicts a story of an American Dream decked out in rhinestones and crucifixes. What,</span><span style="font-weight: 400;"> after all, could be more American than reveling in ill-gotten gains while preaching the gospel of divinely sanctioned prosperity?</span></p>
<p><span style="font-weight: 400;">The biopic is directed by <strong>Michael Showalter</strong> (<em>The Big Sick</em>) and based on <a href="https://en.wikipedia.org/wiki/The_Eyes_of_Tammy_Faye_(2000_film)" target="_blank" rel="noopener">the 2000 documentary of the same name</a>. Like its source material, the movie focuses on</span><span style="font-weight: 400;"> Tammy Faye Bakker&#8217;s personal faith, her oddity in the evangelist boys club, and the looming merger of conservative politics and Christianity in 1980s America. The result is a uniformly watchable portrait that captures Tammy Faye’s unique spark as well as her complicity in one of the country’s most notorious fraud cases.</span></p>
<p><span style="font-weight: 400;">Chastain’s work in the movie is worth the price of admission alone. Her performance could easily have been supported by nothing more than prosthetics and a funny accent. But Chastain’s conviction and obvious affection for her subject shine through all that latex. Her Tammy Faye is airheaded, strong-willed, and contagiously compassionate. </span><span style="font-weight: 400;">Her physical transformation is at times distracting, but </span><span style="font-weight: 400;">any attempt to skirt around the spectacle of Tammy Faye Bakker would undermine why her story captivates in the first place.  </span></p>
<p><span style="font-weight: 400;">As Jim Bakker, Garfield is obviously having an absolute blast. He navigates Jim’s ambition, sensitivity, and cowardice without outright vilification. He’s a fraudster without <span style="color: #000000;">malice</span>, confused and sniveling but by no means a charlatan peddling snake oil. </span><span style="font-weight: 400;"><strong>Cherry Jones</strong> and <strong>Vincent D’Onofrio</strong> are both fantastic in supporting roles as Tammy’s stern mother Rachel and the conservative televangelist <a href="https://en.wikipedia.org/wiki/Jerry_Falwell_Sr." target="_blank" rel="noopener">Jerry Falwell Sr.</a>, respectively. Jones, in particular, brings a tender likeability to a Midwestern matriarch who cannot wrap her head around her daughter&#8217;s determined quest for the limelight.</span></p>
<p><span style="font-weight: 400;"><i>The Eyes of Tammy Faye</i> clearly comes from a place of love, which helps maintain its sense of campiness throughout. But it does feel lacking in bite. Granted, there’s a fine line between edge and cynicism, especially considering the fact that this could have easily veered too far into laughing </span><i><span style="font-weight: 400;">at</span></i><span style="font-weight: 400;"> Tammy Faye. If aiming slightly too far to one side allows the movie to avoid getting mean or punching too hard in the wrong direction, however, the filmmakers have chosen the better of two options.</span></p>
<p><span style="font-weight: 400;">For all the glitz, glam, intrigue, and fraud, there are a handful of tender scenes peppered throughout the movie that wind up being the moments that linger. For instance, after her mother’s funeral, Tammy Faye sits in the pews with her stepfather, Fred (<strong>Fredric Lehne</strong>). Together, they lighten the mood and reminisce. It’s a brief scene with a character who exists at the periphery of the story, but it’s a genuinely sweet and human moment that grounds <i>The Eyes of Tammy Faye</i>&#8216;s more outlandish impulses.</span></p>
<p><span style="font-weight: 400;">Covering several decades and multiple chapters in Tammy Faye&#8217;s life, the movie has a lot on its plate. For the most part, it does an admirable job of touching on the key aspects of Tammy Faye&#8217;s story. But with its generally light tone and the limits of a two-hour run time, there’s no way it could have captured it all. </span></p>
<p><span style="font-weight: 400;">An integral part of Tammy Faye’s story is her support for the LGBTQ+ community and her groundbreaking support and empathy for those living with AIDS. Her</span><span style="font-weight: 400;"> interview with Steven Pieters (<strong>Randy Havens</strong>), a gay Christian AIDS activist, is accurately relayed in the movie and makes for one of its more memorable scenes. It’s a touching moment whose importance will be immediately understood even by those without any prior knowledge of Tammy Faye&#8217;s outreach at the height of the AIDS crisis. However, this aspect of her life still could have been featured more prominently throughout. </span></p>
<p><span style="font-weight: 400;">There are times when the movie muddles the message of whether Tammy Faye’s support of the LGBTQ+ community is coming from her sincere beliefs or motivated by her desire to distinguish herself from the more extreme and politically reactionary televangelists, particularly Falwell. Those familiar with Tammy Faye know the answer is the former. By glazing over the specifics of her allyship, though, the movie leaves the door open for her queer activism to come across as manufactured and inauthentic.</span></p>
<p><span style="font-weight: 400;">Ultimately, considering Tammy Faye’s larger-than-life persona, her vast legacy, and the grand spectrum of experiences throughout her career, there is only so much that a feature-length biopic can cover. The movie opts for narrative breadth over depth, leaving Chastain’s performance to fill in the nuances of its subject. She’s up for the task and will surely emerge as a worthy Oscar frontrunner. As far as well-meaning but flawed biopics go, <em>The Eyes of Tammy Faye</em> would make for one of the better awards season darlings. </span></p>
        <div class="flex justify-items">
                    </div>
          
        
        <p>Related Topics: <a href="https://filmschoolrejects.com/topics/tiff/" rel="tag">Toronto International Film Festival (TIFF)</a></p>
        <!-- AUTHOR BOX -->
<div class="gray-bg p-4 border small mb-5">
    <div class="row align-items-center text-md-center">
        <div class="col-md-2">
            <img src="https://filmschoolrejects.com/wp-content/uploads/2019/07/meg.jpg" class="circle img-fluid" width="100px" height="100px">
        </div>
        <div class="col-md">
            Meg Shields is the humble farm boy of your dreams and a senior contributor at Film School Rejects. She currently runs three columns at FSR: The Queue, How'd They Do That?, and Horrorscope. She is also a curator for One Perfect Shot and a freelance writer for hire. Meg can be found screaming about John Boorman's 'Excalibur' on Twitter here: <a href="https://twitter.com/TheWorstNun">@TheWorstNun</a>. (She/Her).        </div>
    </div>
</div>
        
        <!-- START RECOMMENDED READING 1 -->
                                    <section class="recommended py-5">
                <h3>Recommended Reading</h3>
                
                <div class="row">
                                                                        <li class="recommended-post">
                                <a href="https://filmschoolrejects.com/dune-glossary/" title="&#8216;Dune&#8217; Terminology 101: An Essential Glossary for the Uninitiated">
                                    <h4>&#8216;Dune&#8217; Terminology 101: An Essential Glossary for the Uninitiated</h4>
                                    <span class="small-arc dark-gray">Prepare for Denis Villeneuve&#8217;s new movie adaptation with this handy vocab lesson.</span>
                                </a>
                            </li>
                                                    <li class="recommended-post">
                                <a href="https://filmschoolrejects.com/the-guilty-review/" title="TIFF 2021: &#8216;The Guilty&#8217; is a Heavy-Handed Remake of a Better Thriller">
                                    <h4>TIFF 2021: &#8216;The Guilty&#8217; is a Heavy-Handed Remake of a Better Thriller</h4>
                                    <span class="small-arc dark-gray">Antoine Fuqua&#8217;s version is thrilling but ultimately redundant.</span>
                                </a>
                            </li>
                                                    <li class="recommended-post">
                                <a href="https://filmschoolrejects.com/the-worst-person-in-the-world-review/" title="TIFF 2021: &#8216;The Worst Person in the World&#8217; is the Best Rom-Com in Years">
                                    <h4>TIFF 2021: &#8216;The Worst Person in the World&#8217; is the Best Rom-Com in Years</h4>
                                    <span class="small-arc dark-gray">Finally, a tragi-rom-com for people who don&#8217;t do tragi-rom-coms.</span>
                                </a>
                            </li>
                                                    <li class="recommended-post">
                                <a href="https://filmschoolrejects.com/dashcam-review/" title="TIFF 2021: &#8216;Dashcam&#8217; is an Abysmal Low-Point for Found Footage">
                                    <h4>TIFF 2021: &#8216;Dashcam&#8217; is an Abysmal Low-Point for Found Footage</h4>
                                    <span class="small-arc dark-gray">Annoying and artless, Rob Savage&#8217;s latest screen-life film can&#8217;t even manage to use its format well.</span>
                                </a>
                            </li>
                                                            </div>
            </section>
                <!-- END RECOMMENDED READING -->
		
		<div id="rc-widget-80b056" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="217419"></div>
<script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
         
    </article>
    <!-- START ARTICLE -->
    
</div>
    
<!-- START FOOTER -->		 
<footer class="footer blue-bg py-5">
    <div class="container text-center white small">
            <strong>&copy; 2021 Reject Media, LLC. All Rights Reserved. <a href="/privacy-policy/">Privacy Policy.</a></strong>    
    </div>    
</footer>
<!-- END FOOTER -->

<script type="text/javascript">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</script><script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/filmschoolrejects.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"e85e5ec966","disable_ajax_form":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.1.17' id='ppress-frontend-script-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-content/plugins/agg-smart-gif/assets/js/agg-smart-gif.js?ver=1.0.0' id='agg-smart-gif-plugin-js-js'></script>
<script type='text/javascript' src='https://filmschoolrejects.com/wp-includes/js/wp-embed.min.js?ver=5.8' id='wp-embed-js'></script>

</body>
</html>